
 

 

 

What are my
choices for
formatting lists? 

 

 There are three different types of lists to choose from 
when you are creating a list on a web page:

●     

Unordered Lists
●     

Ordered Lists
●     

Definition Lists

An unordered, or bulleted, list is a sequence of text 
lines in no particular order. Each line is preceded by a 
bullet or, if you choose, another marker. The following 
is an example of an unordered list: 

■     

Unordered List 
■     

Ordered List 
■     

Definition List

An ordered, or numbered, list is a sequence of text 
lines in a necessary order. Each line is numbered 
consecutively with an Arabic numeral (1,2,3, ...) or, if 
you choose, a capital or small Roman numeral ("I, II, 
III, ..." or "i, ii, iii, ...") or letter ("A, B, C, ..." or "a, b, 
c, ..."). The following is an example of an ordered list: 

1.  
Boil water.

2.  
Pour water into a cup.

3.  
Add instant soup mix.

4.  Stir.

A definition list is composed of items followed by an 
indented description. This type of list is most useful for 
creating a glossary on a web page. The following is an 

 



example of a definition list:

F12
Press the function key F12 anytime to view your 
Dreamweaver web page within your active browser.
F1
Press the function key F1 anytime to access the 
Dreamweaver help pages.

 

  

  How do I create
an unordered list?

 To create an unordered list:

1.  
Pull down the Text menu.

2.  
Point to List and select Unordered List from the 
fly-out menu:

3.  
Type your text.

4.  
When you are done, press the Enter key to add 
the next item in the list. 

 

Changing the Bullet Style of an Unordered List 

To change the bullet style for all the items within an 
unordered list:

 



Click on any list item.
2.  

Pull down the Text menu.
3.  

Point to List and select Properties from the fly-
out menu:

The List Properties dialog box will appear:

   



    4.  
Click on the drop down arrow to the right of the 
Style box to see the available bullet styles.

5.  
Select the style you want.

6.  
Click OK to see the change.

Example: The bullet style in the following list has been 
changed to a square:

■     

Unordered List
■     

Ordered List
■     

Definition List

 

   

 

Changing the Style for Just One List Item 

Any change to a single list item affects all items from 
the position of this item down to the bottom of the list. 
Therefore, you may need to format the individual item 
and then reformat the listed items following it. 

To change the style for an individual item within the 
unordered list:

1.  
Click the list item you wish to re-format.

2.  
Pull down the Text menu.

3.  
Point to List and select Properties from the fly-
out menu. The List Properties dialog will 
appear.

4.  
In the List Item section, click on the drop down 
arrow to the right of the New Style Box:

 



  

 

 

    5. Select the style you want.
6. Click on OK.

 

Example: Three different styles have been applied to 
the unordered list bullets below: 

●     

Unordered List
❍     

Ordered List
■     

Definition List

Note: When you indent list items within an unordered 
list, Dreamweaver automatically applies a new style to 
the inner list items, like this:

●     Unordered List Styles 
❍     Bullet
❍     Circle
❍     Square 

●     Ordered List Styles 
❍     Number
❍     Roman Small
❍     Roman Large
❍     Alphabet Small
❍     Alphabet Large

 

  



  How do I create
an ordered list?

 To create an ordered list:

1.  
Pull down the Text menu.

2.  
Point to List and select Ordered List from the fly-
out menu:

3.  
Type your text.

4.  
When you are done, press the Enter key to add 
the next item in the list. 

Changing the Numeric Style of an Ordered List 

To change the numbering style for all the items within 
an ordered list: 

1.  
Click on any list item.

2.  
Pull down the Text menu.

3.  
Point to List and select Properties from the fly-
out menu:

 



The List Properties dialog box will 
appear:

   

    4.  
Click on the drop down arrow to the right of the 
Style box to see the available bullet styles.

5.  
Select the style you want.

6.  
Click OK to see the change.

The style of the following ordered list is changed to 
Roman Small:

i.  
Unordered List

ii.  
Ordered List

iii.  
Definition List

 



Note: When you indent list items within an ordered list, 
Dreamweaver automatically applies a new numbering 
style to the inner list items:

1.  Unordered List Styles 
i.  Bullet

ii.  Circle
iii.  Square 

2.  Ordered List Styles 
a.  Number
b.  Roman Small
c.  Roman Large
d.  Alphabet Small
e.  Alphabet Large

  

 How do I create a 
definition list?

 To create a definition list:

1.  
Pull down the Text menu.

2.  
Point to List and select Definition List from the 
fly-out menu.

3.  
Type your text.

4.  
When you are done, press the Enter key to add 
the next item in the list. 

 

 

 

 



 What are tables?  Tables are areas of a web page that are divided into 
rows and columns. The intersection of the rows and 
columns make cells, and objects such as text or 
graphics can be inserted into cells.

Here is an example of a table with three rows and three 
columns:

Name Qz.1 Qz.2

John 5 4

Peter 5 3

 

 

  

 Why use tables?  Tables are generally used to store data in a tabular 
format. In addition, tables can be used to place text 
and/or graphics side-by-side on a web page.

 

  

How do I create 
tables?

 To create a table in Dreamweaver:

1. Pull down the Insert menu and select Table:

The Insert Table dialog box will appear:

 



 

 

 

  2) Enter the desired number of rows and columns 
into the Rows and Columns entry boxes.

3) Enter the desired width of the table in the Width 
entry box. You can enter the value either in pixels, or in 
a percentage of the width of the browser window:

If you choose a percentage, the table will resize itself 
whenever the width of the browser window is changed. 
If you choose a pixel measurement for your table, the 
table size will not change when the window is resized.

4) Enter the desired thickness of the border around 
the outside of the table: type the value (in pixels) into 
the Border entry box. An entry of 1 will put a thin line 
around the table; increase that number for a thicker 
outline. An entry of zero will make the border, as well as 
the grid lines within the table, disappear.

Here is an example of how the border setting can affect 
the look of your table:

 



   

   

   

border = 1 pixel

   

   

   

border = 5 pixel

5) Enter the desired thickness of the grid lines 
within the table: type the value (in pixels) into the Cell 
Spacing entry box. An entry of zero will create very 
thin grid lines; increase that number for thicker lines. 
(To make the gridlines disappear altogether, enter zero 
in the Border entry box.)

Here is an example of how the cell spacing setting can 
affect the look of your table:

   

   

   

cell spacing = 0 pixel

   

   

   

cell spacing = 5 pixel

6) Enter the desired white space, or padding, 
between the grid lines and the contents of the cell: type 
the value (in pixels) into the Cell Padding entry box. 
An entry of zero will make sure that there is no space 
between the contents of the cell and its border; increase 
that number if you want some white space between the 
contents of the cell and the cell edges.

Here is an example of how the cell padding setting can 
affect the look of your table:

   

 
Grid

 

   

cell padding = 0 pixel

   

 Grid  

   

cell padding = 5 pixel



7) To create the table, click OK.

 

  

How do I modify 
Tables?

 To resize of the rows or columns in a table, drag the 
gridlines with your mouse.

To modify your table structure:

1) Click anywhere inside the table. (If you want to make 
a change to a specific cell or group of cells, select it with 
your mouse.) 

2) Pull down the Modify menu, point to Table, and 
then click on the desired command from the fly-out 
menu: 

 

   



      

Some of the most frequently used options include:

●     Select Table -- selects the entire table
●     Merge Cells -- combines two or more cells into 

one single large cell
●     Split Cell -- divides the current cell into two or 

more rows or columns
●     Insert Row -- inserts a new row on the top of the 

current row
●     Insert Column -- inserts a new column to the left 

of the current column
●     Insert Rows or Columns -- inserts a given number 

of rows or columns before or after the current 
rows or columns

●     Delete Row -- removes the current row from the 
table

●     Delete column -- removes the current column 
from the table

 

 

   

 Practice  Take the web page you have been working on 
(welcome.htm) and add a table:

1) Create a table whose width is 75% of the window; it 
should have 4 rows and 2 columns, and a 2 pixel 
border.

2) Merge the cells in the top row so that you have one 
long cell across the top of the table. (Hint: use the 
Merge Cells command.)

3) Enter some text into some of the table cells.

4) Type a title for your table in the top row. Center the 
title using the Text->Align command, and make the title 
bold.

 

 

 

 



 

 What are frames?  Frames are used to split a web page into two or more 
sections. Each section displays a different html file, with 
the combination forming the web page.

Frames can be used to separate constant objects of a 
web site (such as navigation buttons) from changing 
ones (such as the page content). Why would that be 
useful? Here's one example: You have a navigation bar 
at the top of every page in your site. If you make a 
change to the navigation, you will have to update every 
individual web page that has that navigation bar. 
However, if your navigation bar exists in just one html 
file that you display on every page, you only have to 
make the change once and maintainance is much 
easier.

Another benefit of using frames is that you can control 
the scrolling of each frame area independently. This 
means that you can have objects on your page (such as 
a header) that never scroll "off" the screen, while other 
parts can scroll.

Early browsers (version four and lower) did not support 
the use of frames very well, and web designers are 
inclined to avoid them. However, more recent browsers 
have reduced many of the navigation and printing 
difficulties that were associated with early browsers, and 
the judicious use of frames is OK.

 

 

 

 How do I
create frames?

 

 

 

 

 To create frames in your web page:

1. Click in the window you want to divide into frames.

2. Pull down the Insert menu, point to Frames, and 
select an option from the menu:

 



Choices include:

  Left -- splits the window into two vertical 
frames, one narrow and one wide. The 
narrow one is on the left.

 

  Right -- splits the window into two vertical 
frames, one narrow and one wide. The 
narrow one is on the right.

 

  Top -- splits the window into two horizontal 
frames, one short and one tall. The short 
one is on the top.

 

  Bottom -- splits the window into two 
horizontal frames, one short and one tall. 
The short one is on the bottom.

 

  Left and Top -- splits the window into four 
frames: a narrow one across the top, a 
narrow one along the left, a small one in 
the corner where the two other frames 
cross each other, and the main frame 
bottom right.

 



  Left Top -- splits the window into three 
frames. A narrow vertical frame on the left 
is created first, then the remaining frame 
is split horizontally, with a narrow frame 
across the top and the main frame bottom 
right.

 

  Top Left -- splits the window into three 
frames. A narrow horizontal frame across 
the top is created first, then the remaining 
frame is split vertically, with a narrow 
frame on the left and the main frame 
bottom right.

 

  Split -- splits the window into four equal 
frames.

 

 

 

 How do I edit
my web page
if it has frames?

 

 

 Changing the layout of your frames is easy:

●     

To resize a frame, drag the frame border to 
where you want it.

●     

To delete a frame, drag the frame border off the 
page, or drag it on top of the border of another 
frame.

●     

To split a frame into two smaller frames, alt-drag 
a frame border to where you want the new frame 
border to appear.

For the purpose of adding content, each frame in your 
window can be treated as a separate web page. Simply 
click in the frame you want to edit, then type text, 
insert graphics, create tables, etc. as usual.

 

 

 



 What's really 
happening behind the 
scenes?

 Although you don't necessarily see it when you are 
using Dreamweaver, a web page with frames is really 
composed of several html documents. Each frame 
displays its own html document. 

There is one additional html file, called the frameset 
document. This document contains the frameset 
definition, which tells the browser how to arrange the 
frames on the page, and indicates which html document 
should be displayed in each frame.

 

 

 

 How do I save
all these files?

 Because it contains several html files, saving a web 
page with frames is a little more complicated than 
saving a web page without frames.

●     

To save just one of the html documents, click in 
the frame that is displaying that document, pull 
down the File menu and select Save Frame.

●     To save all of the html documents (both the 
displayed html pages and the frameset 
document), pull down the File menu and select 
Save All Frames.

●     To save just the frameset document, you first 
have to select the entire frameset area of the 
web page. Do this by clicking on one of the frame 
boundaries (indicated by the red arrows below):

You will know that the frameset area has 
been properly selected by the dotted lines 
that appear along the frame boundaries:

 



Once the selection has been made, then 
pull down the File menu and select Save 
Frameset.

 How do I change
the properties
of a frame?

 There are various ways in which you can customize your 
frame settings. Some of the things you can specify for 
each frame include:

●     

the name of each frame
●     the html file associated with each frame
●     the frame margins
●     whether the user can scroll the frame
●     whether the frame can be resized
●     whether the frame border is visible, and if so, in 

what color

Some of the things you can specify for the entire 
frameset include:

●     

dimensions of the frames 
●     

the color of the borders between frames
●     

width of the borders between frames

To change frame properties:

1. Pull down the Window menu and select Properties 
to open the Property Inspector:

 



  

    
The Property Inspector lets you easily view and edit 
properties for the page element that is currently 
selected (text, a graphic, a table, a frame, etc.) The 
contents of the Property Inspector will change 
depending upon what page element is selected. (You 
will learn more about the Property Inspector in Lesson 
11.)

2. Pull down the Window menu and select Frames to 
open the Frames panel:

The Frames panels lets you quickly view the frame 
layout of your entire web page. You can select an 
individual frame by clicking on it in the Frames panel, or 
you can select the entire frameset by clicking on its 
border in the Frames panel.

3. Once you have selected the desired frame or 
frameset, the contents of the Properties Inspector will 
change to show the appropriate options. To change any 
settings, just edit it in the Properties Inspector.

 

 

 



What is the
Object Palette?

 The object palette is a floating tool bar that contains 
buttons for inserting objects such as images, tables, and 
rollover images. (See the picture to the left.)

To display or hide the object palette, pull down the 
Window menu and select Object.

The object palette has eight different "panels" — that is, 
collections of related buttons. If you look at the object 
palette to the left, you will see the word "Common" at 
the top. If you click on the down-arrow, you can select 
from the other available panels. For example, the 
animation below shows the Frames panel being selected:

As you can see from the animation, the object palette 
has eight different panels, and each one has a different 
set of buttons that will be displayed, representing 
different objects that can be inserted into your web 
page.

 

 



 

How do I
insert an object?

 

To insert a particular object into your web page, click its 
button in the object palette, or drag it from the object 
palette into the document window. When you insert an 
object, it will appear at the location of your cursor in the 
document window.

Note: All the objects represented in the object palette 
can also be inserted into the document window by 
pulling down the Insert menu and selecting the 
appropriate object.

 

  

 What are some
of the objects 
I can insert?

 There are numerous objects that can be inserted into a 
web page. As we saw above, these are grouped into 
panels of related buttons. Below we'll cover just a few of 
the most frequently used panels and objects.

The Common panel includes many of the most 
commonly used objects. Here is a description of some of 
the more simple objects: 

Image: Inserts a graphic image.

Table: Inserts a table. (See the lesson on Tables).

Horizontal rule: Inserts a horizontal rule.

Rollover image: Inserts a rollover image. (See 
the lesson on Rollovers).

Date: Inserts a variable which will display the 
current date whenever the page is viewed.

Email: Inserts a link to an email address.

The Frames panel includes the objects to create a 
frameset. The buttons below divide the current web 
page into frames (see Lesson 9 for more information 

 



about frames):

Creates a narrow left vertical frame and a wide 
right vertical frame.

Creates a wide left vertical frame and a narrow 
right vertical frame.

Creates a narrow top horizontal frame and a wide 
bottom horizontal frame.

Creates a wide top horizontal frame and a narrow 
bottom horizontal frame.

Creates a narrow horizontal top frame, a narrow 
vertical left frame, a small top left corner frame, 
and a large lower right corner frame.

Creates a narrow left vertical frame, and divides 
the right-hand frame into two smaller frames.

Creates a narrow top horizontal frame, and divides 
the bottom frame into two smaller frames.

Creates four equal-sized frames.

The Forms panel includes the objects to create a form. 
Here are some of the more common Form objects: 

Form: Inserts a new form.

Text Field: Inserts a text field box into the form 
for data input.

Button: Inserts a button into the form. 

Check box: Inserts a check box into the form.

Radio button: Inserts a radio button into the 
form.

 

    

 



 What is the
Property Inspector?

 The Property Inspector is a floating palette that displays 
all the properties, or formatting, for a selected object. 
The Property Inspector lets you quickly and easily view 
or modify those properties. In previous lessons we 
learned how to format text, tables, and images; the 
Property Inspector gives you shortcuts for changing 
those properties, all in one place!

Here's what the Property Inspector looks like when you 
first open it: 

 

  

  

 

 The properties displayed in the Property Inspector vary 
with the type of object that's currently selected. In other 
words, the properties in the Property Inspector will be 
different for text, tables, table cells, images, etc.

To display or hide the Property Inspector, pull down the 
Window menu and select Properties:

The Property Inspector will appear. 

To see the properties of an object, select the object with 
your mouse. The contents of the Property Inspector will 
immediately change. 

Click the arrow in the bottom-right corner to display all 
properties, not just the most-frequently used ones.

In the rest of this lesson, we will cover some of the 
common objects whose properties can be set in the 
Properties Inspector floating palette.

 

  



 Text Properties  With text selected, the Property Inspector looks like this:  

  

   

You can quickly change the following text properties 
right in the Inspector:

 Format: To set the paragraph format

 Font: To select the font family

 Font Size: To set the font size

 Font Color: To color the text

Left Align: To left align the text

Center: To center the text

Right Align: To right align the text

Bold: To bold the text

Italic: To italicize the text

Unordered List: To create or cancel an 
unordered list (see lesson on Lists)

Ordered List: To create or cancel an ordered 
list (see lesson on Lists)

Indent: To indent text

Outdent: To outdent indented text

 Link: To turn the text into a link

(See Lesson 4 for more information on formatting text; 
see Lesson 13 for how to create links.)

 

 

 

 Image Properties  With an image selected, the Property Inspector looks like 
this:

 



  

   

Here are some of the graphic image properties that you 
can quickly change right in the Inspector:

 W: To set the width of the image (resize)

 H: To set the height of the image (resize)

 Src: To specify the image source

 Link: To turn the image into a link

 Align: To align the image

Left Align: To left align the image

Center: To center the image

Right Align: To right align the image

 Border: To enter (in pixels) the desired border 
width around the image

 Alt: To set an Alt tag for the image (text that 
displays while the image is loading)

 

 

  

 Table Properties  With a table selected, the Property Inspector looks like 
this:

 

  



    

Here are some of the table properties that you can 
quickly change right in the Inspector:

 Rows: To set the number of rows

 Cols: To set the number of columns

 W: To specify the table width

 H: To specify the table height

 CellPad: To specify the cell padding

CellSpace: To specify the cell spacing

  Align: To change the alignment of the table

 Border: To enter (in pixels) the desired border 
width around the table

 Brdr Color : To set the color of the border 
around the table (if any)

 Bg Color : To set the background color of the 
table

 Bg Image: To set a background image for the 
table (if any)

(See Lesson 8 for more information on creating and 
formatting tables.)

 

 

 

 Cell Properties  With a cell selected, or with the blinking insertion bar 
inside a cell, the Property Inspector looks like this:

 

  



    

Since cells can contain text, the text formatting options 
are still available in the Inspector. Below them are some 
of the cell properties that you can quickly change right in 
the Inspector:

Join Cells : To join the selected cells together 
into one cell

Split Cell : To split the selected cell into smaller 
cells

 Horz: To set the horizontal alignment of the 
contents of the cell (left, center, right)

 Vert: To set the vertical alignment of the 
contents of the cell (top, middle, bottom) 

 W: To specify the cell width

 H: To specify the cell height

 Brdr Color: To set the color of the border 
around the cell (if any)

 Bg (Color): To set the background color of the 
cell

 Bg (Image): To set a background image for the 
cell (if any)

 

 

 

 



 What is a
template?

 Web pages within the same site usually share common 
characteristics such as layout, navigation bar, titles, 
tables, and more. A template reduces your development 
time by allowing you to create those elements once for 
all the pages within your web site. An existing HTML 
document can be saved as a template and then be used 
to create other documents based on the same format. 
Templates are associated with specific web sites; you 
can have more than one template for a site.

 

 

  

How do I
create a template?

 To create a new template in Dreamweaver:

1.  
Pull down the Window menu and select 
Templates. The Assets palette will open, and 
the Templates icon in the left column will be 
selected:

2.  
Pull down the palette menu and select New 
Template. An untitled template is added at the 
end of the template list:



3.  
Type a name for the template, then press Enter.

4.  
Double-click the template's name to open the 
template file.

5.  Put all of the static elements for the site into the 
page (e.g., header graphic, footer, table 
structure, navigation).

6.  Mark the area or areas you want to be editable 
(in other words, the areas that can change from 
page to page). To do this, click in the area you 
want to be editable, then pull down the Modify 
menu, point to Templates, and select New 
Editable Region from the fly-out menu.

7.  You will be prompted to name the area; type in a 
name and click OK.

8.  
Pull down the File menu and select Save to save 
the template.

To save an existing HTML document as a template:

1.  
Open the document you wish to use as a 
template.

2.  
Pull down the File menu and select Save as 
Template. The Save As Template dialog box 
will appear:



 

 

 

  3.  
In the "Site" pull-down menu, select the site you 
want the template to apply to. 

4.  
In the "Save As" text box type a name for the 
template.

5.  Click the Save button.

 

 

 How do I
modify a template?

 To modify an existing template:

1.  Pull down the Window menu and select 
Templates. The Assets dialog box will appear 
with the Templates icon selected in the left-hand 
column, and the list of templates will appear to 
the right.

2.  Double click the name of the template you want 
to modify to open it.

3.  Make all the edits and changes.

4.  Pull down the File menu and select Save to save 
the template.

 

  



 How do I use the 
template I've created?

 To create a new document using an existing template:

1.  
Pull down the File menu and select New from 
Template. The Select Template dialog box will 
appear:

1.  
Select the site from the "Site" pull-down menu.

2.  
Select the name of the desired template from the 
"Templates" list.

3.  
Click the Select button. A new untitled document 
based upon the selected template will be created 
and opened for you to work in.

You will only be able to make changes to the parts of 
this new document that were editable in the template. 
The non-editable features (like headers, navigation, 
etc.) can't be changed.
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